Triangulation |
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.

System Object
Autodesk.Revit.DB TriangulationInterface
Autodesk.Revit.DB TriangulationInterfaceForTriangulatedSolidOrShell
Autodesk.Revit.DB TriangulationInterface
Autodesk.Revit.DB TriangulationInterfaceForTriangulatedSolidOrShell
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Name | Description | |
---|---|---|
![]() | TriangulationInterfaceForTriangulatedSolidOrShell | Construct an interface object for a TriangulatedSolidOrShell. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from TriangulationInterface ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The vertex and triangle indices used by this class treat the triangulated solid or shell as if all the vertices and triangles of the different shell components were collected into single sets of vertices and triangles, respectively. For example, if a solid has two shell components and the first has ten vertices while the second has five vertices, vertexIndex 6 refers to vertex[6] of the first shell component, and vertexIndex 12 refers to vertex[2] of the second shell component. You can use the class TriangulationInterfaceForTriangulatedShellComponent to get a faceting of an individual shell component.