GetMaterialId Method


Compound Structure Get Material Id Method

Retrieves the material element id of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ElementId GetMaterialId(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

ElementId
The material element id.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
See Also