ProjectLocationSet Class


Project Location Set Class

An set that contains project locations.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB ProjectLocationSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ProjectLocationSet : APIObject, 
	IEnumerable

The ProjectLocationSet type exposes the following members.

Constructors
Name Description
Public method ProjectLocationSet Initializes a new instance of the ProjectLocationSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of project locations that are in the set.
Top
Methods
Name Description
Public method Clear Removes every project location from the set, rendering it empty.
Public method Contains Tests for the existence of a project location within the set.
Public method Erase Removes a specified project location from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified project location into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also