SetEndTreatmentTypeId Method


Rebar Shape Set End Treatment Type Id Method

Note: This API is now obsolete.

Sets the EndTreatmentType id at the specified rebar shape end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please create a new shape using RebarShape.Create(Document doc, RebarShapeDefinition definition, RebarShapeMultiplanarDefinition multiplanarDefinition, RebarStyle style, StirrupTieAttachmentType attachmentType, int higherEnd, RebarShapeTerminationsData rebarShapeTerminationsData) instead.")]
public void SetEndTreatmentTypeId(
	ElementId endTreatmentId,
	int end
)

Parameters

endTreatmentId ElementId
The id of an EndTreatmentType element, or invalidElementId if the rebar shape should have no end treatment at the specified end.
end Int32
0 for the start end treatment, 1 for the end end treatment.
Exceptions
Exception Condition
ArgumentException end not a valid shape end -or- the parameter endTreatmentId is not an EndTreatmentType element.
ArgumentNullException A non-optional argument was null
See Also