ViewportPositioning Property


Viewport Viewport Positioning Property

Note: This API is now obsolete.

Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This property is deprecated in Revit 2026 and may be removed in a future version of Revit. Please use ViewAnchor instead.")]
public ViewportPositioning ViewportPositioning { get; set; }

Property Value

ViewportPositioning
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also