IPoint |
Implement this method to fill the provided buffer with points up to the number of maximum points for which the buffer was allocated.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- buffer IntPtr
- Memory buffer into which the points should be written. The buffer was allocated by Revit and it is guaranteed to be valid for the duration of the call.
- bufferSize Int32
- The maximum number of CloudPoint objects that may be copied into the buffer.
Return Value
Int32The actual number of CloudPoint objects placed in the buffer (can be less than the length of the buffer). If there are no more points available, return 0.