Vertex |
A stream that can be used to write vertices of type VertexPositionNormal into a buffer (see VertexBuffer ).

System Object
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormal
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormal
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The VertexStreamPositionNormal type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from VertexStream ) |

Name | Description | |
---|---|---|
![]() | AddVertex | Inserts a VertexStreamPositionNormal into the stream and associated buffer. |
![]() | AddVertices | |
![]() | Dispose | (Inherited from VertexStream ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |