Checker Class


Checker Class

A static class that provides access to the property names that appear in the Checker visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Checker

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Checker

The Checker type exposes the following members.

Properties
Name Description
Public property Static member CheckerColor1 The property labeled "Color 1" from the "Checker" schema.
Public property Static member CheckerColor2 The property labeled "Color 2" from the "Checker" schema.
Public property Static member CheckerSoften The property labeled "Soften" from the "Checker" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Checker" schema.
Public property Static member TextureOffsetLock The property labeled "Offset Lock" from the "Checker" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Checker" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Checker" schema.
Public property Static member TextureRealWorldScaleX The property labeled "Size X" from the "Checker" schema.
Public property Static member TextureRealWorldScaleY The property labeled "Size Y" from the "Checker" schema.
Public property Static member TextureScaleLock The property labeled "Scale Lock" from the "Checker" schema.
Public property Static member TextureURepeat The property labeled "U Repeat" from the "Checker" schema.
Public property Static member TextureVRepeat The property labeled "V Repeat" from the "Checker" schema.
Public property Static member TextureWAngle The property labeled "Rotation" from the "Checker" schema.
Top
See Also