IndexStream Class


The base class for DirectContext3D index streams, which are used to write vertex indices into buffers.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017

Syntax

C#
public class IndexStream : IDisposable
Visual Basic
Public Class IndexStream _
	Implements IDisposable
Visual C++
public ref class IndexStream : IDisposable

Remarks

There is a corresponding stream type for each type of primitive (point, line, or triangle). The process of putting vertex indices into a buffer involves using a stream-buffer pair as follows (see Autodesk::Revit::DB::DirectContext3D::IndexBuffer).

  1. Map the index buffer.
  2. Get a stream for the appropriate primitive type from the buffer.
  3. Add sequences of indices corresponding to primitives of the same type to the stream. The indices will be written into the buffer that was used to create the stream.
  4. Unmap the buffer.

Alternatively to using streams, it is possible to write data into a buffer using a handle to its mapped memory.

Inheritance Hierarchy

See Also