Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostPointReference
- Type: Autodesk.Revit.DB Reference
The reference of the host point.
Return Value
If creation is successful then a new PointRelativeToPoint object is returned, otherwise an exception with failure information will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument hostPointReference is a null reference ( Nothing in Visual Basic) . |