PassesFilter Method (Element)


Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public bool PassesFilter(
	Element element
)
Visual Basic
Public Function PassesFilter ( _
	element As Element _
) As Boolean
Visual C++
public:
bool PassesFilter(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB Element
The element.

Return Value

True if the element is accepted by the filter. False if the element is rejected.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also