Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- iSegment
- Type: System Int32
Index of the segment (0 to NumberOfSegments - 1).
- paramId
- Type: Autodesk.Revit.DB ElementId
Id of a parameter to drive the radius. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
- measureToOutsideOfBend
- Type: System Boolean
Choose between two possibilities for the references of the radius dimension. If true, measure to the exterior face of the bar. If false, measure to the interior face.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | iSegment is not between 0 and NumberOfSegments. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Reinforcement_Length or UT_Angle. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |