Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- edgeReference
- Type: Autodesk.Revit.DB Reference
The edge reference.
- faceReference
- Type: Autodesk.Revit.DB Reference
The face reference.
- orientWithEdge
- Type: System Boolean
Return Value
A new PointOnEdgeFaceIntersection object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument edgeReference or faceReference is a null reference ( Nothing in Visual Basic) . |