Creates a FabricArea from an array of curves.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DB Document
The document.
- hostElement
- Type: Autodesk.Revit.DB Element
The element that will host the FabricArea. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
- curveLoops
- Type: System.Collections.Generic IList CurveLoop
An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area.
- majorDirection
- Type: Autodesk.Revit.DB XYZ
A vector to define the major direction of the FabricArea.
- majorDirectionOrigin
- Type: Autodesk.Revit.DB XYZ
An origin point of the major direction line
- fabricAreaTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the FabricAreaType.
- fabricSheetTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the FabricSheetType.
Return Value
The newly created FabricArea.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Not all curveLoops in curveLoops are closed and continuous. -or- Not all curveLoops in curveLoops are in the same plane. -or- curveLoops should only contain lines or arcs. -or- The document aDoc does not contain the element hostElement -or- the host Element is not a valid host for Area Reinforcement, Path Reinforcement, Fabric Area or Fabric Sheet. -or- fabricAreaTypeId should refer to an FabricAreaType element. -or- fabricSheetTypeId should refer to an FabricSheetType element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | majorDirection has zero length. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |