Rename Method


Rename the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public bool Rename(
	string newName
)
Visual Basic
Public Function Rename ( _
	newName As String _
) As Boolean
Visual C++
public:
bool Rename(
	String^ newName
)

Parameters

newName
Type: System String
View sheet set name to be renamed as.

Return Value

False if Rename operation fails, otherwise True.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the input name is already existed in current view sheet set list.

See Also