SetShape Method (IList(GeometryObject))


sets the Shape of this object to the supplied collection of Geometry objects. The objects are copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public void SetShape(
	IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub SetShape ( _
	pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void SetShape(
	IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic IList GeometryObject
Shape of this object expressed as a collection of Geometry objects

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also