IsAlmostEqualTo Method (UV, Double)


Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public bool IsAlmostEqualTo(
	UV source,
	double tolerance
)
Visual Basic
Public Function IsAlmostEqualTo ( _
	source As UV, _
	tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
	UV^ source, 
	double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB UV
The vector to compare with this vector.
tolerance
Type: System Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when source is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown when tolerance is less than 0.

See Also