DockablePane Constructor (DockablePaneId)


Gets the pane with identifier %id%.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public DockablePane(
	DockablePaneId id
)
Visual Basic
Public Sub New ( _
	id As DockablePaneId _
)
Visual C++
public:
DockablePane(
	DockablePaneId^ id
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException no dockable pane has been registered with identifier id. -or- the dockable pane with identifier id has not been created yet.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also