Autodesk.Revit.DB.Structure Namespace


Classes

Class Description
Public class AnalyticalConsistencyChecking
Utilities that allow for detection of incorrect or incomplete analytical consistency.
Public class AnalyticalLink
An analytical link element that is used to create connections between other AnalyticalModel elements.
Public class AnalyticalLinkType
An object that specifies the analysis properties for an AnalyticalLink element.
Public class AnalyticalModel
AnalyticalModel represents the Analytical Model portion of a given Structural Element.
Public class AnalyticalModelColumn
An element that represents the structural analytical model column.
Public class AnalyticalModelSelector
Defines a portion of an Analytical Model for an Element.
Public class AnalyticalModelSketchComponent
This is one component of an AnalyticalModelSketch, which exists to provide greater granularity over the Analytical Model than at the Element level.
Public class AnalyticalModelStick
An element that represents a stick in the structural analytical model. Could be one of beam, brace or column type.
Public class AnalyticalModelSupport
Represents one support for an Element, in the realm of the Analytical Model.
Public class AnalyticalModelSurface
An element that represents a surface in the structural analytical model.
Public class AnalyticalModelSweptProfile
Represents an extruded profile swept along a driving curve.
Public class AnalyticalSupportChecking
Utilities that allow for detection of incorrect or incomplete analytical supports.
Public class AreaLoad
An object that represents a force applied across an area.
Public class AreaLoadType
An object that represents a Load type.
Public class AreaLoadTypeSet
A set that contains areaload types.
Public class AreaLoadTypeSetIterator
An iterator to a areaload type set.
Public class AreaReinforcement
An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class AreaReinforcementCurve
An object that specifies the type of a floor in Autodesk Revit.
Public class AreaReinforcementType
An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
Public class BoundaryConditions
An object that represents a force applied across an area.
Public class CodeCheckingParameterServiceData
The data needed by code checking server to perform code checking.
Public class FabricArea
An object that represents an Fabric Area Distribution within the Autodesk Revit project. It is container for Fabric Sheet elements.
Public class FabricAreaType
A FabricAreaType object is used in FabricArea object generation.
Public class FabricReinSpanSymbol
Represents an instance of a Structural Fabric Reinforcement Symbol in Autodesk Revit.
Public class FabricRoundingManager
Provides access to element reinforcement roundings overrides.
Public class FabricSheet
An object that represents an Fabric Sheet Element within the Autodesk Revit project.
Public class FabricSheetType
Represents a fabric sheet type, used in the generation of fabric wires.
Public class FabricWireType
A Fabric Wire Type object that is used in the generation of Fabric Wire.
Public class FamilyStructuralMaterialTypeFilter
A filter used to match families that have the given structural material type.
Public class Hub
Represents a connection between two or more Autodesk Revit Elements.
Public class LineLoad
An object that represents a force/moment applied in a linear manner.
Public class LineLoadType
An object that represents a Load type.
Public class LineLoadTypeSet
A set that contains lineload types.
Public class LineLoadTypeSetIterator
An iterator to a lineload type set.
Public class LoadBase
The LoadBase object is the base class for all load objects within the Autodesk Revit API.
Public class LoadCase
This object represents a load case within the project.
Public class LoadCaseArray
An array that contains load case objects.
Public class LoadCaseArrayIterator
An iterator to an load case array.
Public class LoadCaseSet
A set that contains load cases.
Public class LoadCaseSetIterator
An iterator to a load case set.
Public class LoadCombination
An object that represents a load combination.
Public class LoadCombinationArray
An array that can contain LoadCombination objects.
Public class LoadCombinationArrayIterator
An iterator to an array.
Public class LoadNature
A structural Load nature object.
Public class LoadTypeBase
An object that represents a Load type.
Public class LoadTypeBaseSet
A set that contains load type bases.
Public class LoadTypeBaseSetIterator
An iterator to a load type base set.
Public class LoadUsage
This object represents a load case within the project.
Public class LoadUsageArray
An array that contains load usage objects.
Public class LoadUsageArrayIterator
An iterator to an load usage array.
Public class PathReinforcement
An object that represents an Path Reinforcement within the Autodesk Revit project.
Public class PathReinforcementType
An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
Public class PathReinSpanSymbol
Represents a Path Reinforcement Span Symbol element in Autodesk Revit.
Public class PointLoad
An object that represents a force/moment applied to a single point.
Public class PointLoadType
An object that represents a Load type.
Public class PointLoadTypeSet
A set that contains pointload types.
Public class PointLoadTypeSetIterator
An iterator to a pointload type set.
Public class Rebar
Represents a rebar element in Autodesk Revit.
Public class RebarBarType
A Rebar type object that is used in the generation of Rebar
Public class RebarBarTypeSet
A set that contains RebarBar types.
Public class RebarBarTypeSetIterator
An iterator to a RebarBar type set.
Public class RebarBendData
The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Public class RebarConstrainedHandle
A class representing a handle on a Rebar that can be joined to a reference, such as a host Element's surface or cover, or another Rebar's handle.
Public class RebarConstraint
A class representing a constraint on a handle of a rebar element.
Public class RebarConstraintsManager
A class used to obtain information about the constraints (RebarConstraints) acting on the shape handles (RebarConstrainedHandles) of a Rebar element, and to replace default constraints with user-preferred choices.
Public class RebarCoverType
A named value for a clear cover distance.
Public class RebarCoverTypeSet
A set that contains RebarCover types.
Public class RebarCoverTypeSetIterator
An iterator to a RebarCover type set.
Public class RebarHookType
A Rebar Hook type object that is used in the generation of Rebar.
Public class RebarHookTypeSet
A set that contains RebarHook types.
Public class RebarHookTypeSetIterator
An iterator to a RebarHook type set.
Public class RebarHostData
Interface to rebar-specific data stored in each valid rebar host element.
Public class RebarInSystem
Represents a rebar element that is part of a system.
Public class RebarRoundingManager
Provides access to element reinforcement roundings overrides.
Public class RebarShape
RebarShape specifies the shape type for a Rebar instance.
Public class RebarShapeConstraint
A dimension or other constraint that takes part in a RebarShapeDefinition.
Public class RebarShapeConstraint180DegreeBendArcLength
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the arc length.
Public class RebarShapeConstraint180DegreeBendRadius
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the radius of the arc.
Public class RebarShapeConstraint180DegreeDefaultBend
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.
Public class RebarShapeConstraintAngleFromFixedDir
A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.
Public class RebarShapeConstraintArcLength
An arc-length constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintChordLength
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the straight distance between the arc endpoints.
Public class RebarShapeConstraintCircumference
A circumference constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintDiameter
A diameter constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintFixedSegmentDir
A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.
Public class RebarShapeConstraintProjectedSegmentLength
A constraint that measures the length of a segment as measured by projecting onto a direction that is not parallel to the segment.
Public class RebarShapeConstraintRadius
A radius constraint associated with an arc in a RebarShapeDefinition.
Public class RebarShapeConstraintSagittaLength
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the height of the arc.
Public class RebarShapeConstraintSegmentLength
A constraint that controls the length of a segment.
Public class RebarShapeDefinition
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.
Public class RebarShapeDefinitionByArc
Definition of a shape whose size and position can determined by a single arc.
Public class RebarShapeDefinitionBySegments
Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
Public class RebarShapeMultiplanarDefinition
A specification for a simple 3D rebar shape.
Public class RebarShapeParameters
Class containing functions that create and retrieve shared parameters for RebarShapes.
Public class RebarShapeSegment
Part of a RebarShapeDefinitionBySegments, representing one segment of a shape definition.
Public class RebarShapeSet
An set that contains rebar shapes.
Public class RebarShapeSetIterator
An iterator to a rebar shape set.
Public class RebarShapeVertex
A bend between segments of a rebar shape definition.
Public class RebarSystemSpanSymbol
Represents a Rebar System Span Symbol element in Autodesk Revit.
Public class ReinforcementRoundingManager
A base class providing access to reinforcement rounding overrides for structural elements.
Public class ReinforcementSettings
Provides access to project-wide reinforcement settings.
Public class StructuralConnectionType
A type element that represents a connection symbol applied to structural members.
Public class StructuralFramingUtils
A collection of Structural Framing Utilities.
Public class StructuralInstanceUsageFilter
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.
Public class StructuralMaterialTypeFilter
A filter used to match family instances that have the given structural material type.
Public class StructuralSectionsServiceData
The data needed by section type server to perform type definition.
Public class StructuralSettings
Provides access to project-wide structural settings.
Public class StructuralWallUsageFilter
A filter used to match walls that have the given structural wall usage.
Public class Truss
Represents all kinds of Trusses.
Public class TrussMemberInfo
Provides access to the information of a truss member in Autodesk Revit.
Public class TrussType
Represents a specific type of truss.
Public class TrussTypeSet
A set that contains Truss types.
Public class TrussTypeSetIterator
An iterator to a Truss type set.

Interfaces

Interface Description
Public interface ICodeCheckingParameterServer
Interface for the code checking parameter server to implement.
Public interface IStructuralSectionsServer
Interface for the section type parameter server to implement.

Enumerations

Enumeration Description
Public enumeration AnalyticalAlignmentMethod
Specifies how analytical model is being aligned in space
Public enumeration AnalyticalCurveSelector
Specifies which portion of an Analytical Curve is of interest.
Public enumeration AnalyticalCurveType
Identifies what type of Analytical Model curves should be extracted.
Public enumeration AnalyticalDirection
Specifies a direction for manipulating analytical model.
Public enumeration AnalyticalElementSelector
Specifies a portion of an Analytical Element or the whole element.
Public enumeration AnalyticalFixityState
Specifies the fixity setting of individual degrees of freedom in analytical release conditions.
Public enumeration AnalyticalLoopType
Specifies kind of analytical model loop.
Public enumeration AnalyticalProjectionType
Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts Analytical Projections for all Structural Elements
Public enumeration AnalyticalRigidLinksOption
Specifies how Rigid Links will be made for the Analytical Model.
Public enumeration AnalyticalSupportPriority
Defines how "highly" another Element is giving support for one Element.
Public enumeration AnalyticalSupportType
Indicates what kind of support another Element provides -- Point, Surface, or Curve.
Public enumeration AnalyzeAs
Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.
Public enumeration BoundaryConditionsOrientTo
Specifies boundary condition orientation.
Public enumeration BoundaryConditionsType
This enum declares type of BoundaryConditions.
Public enumeration BracePlanRepresentation
The possible representations for braces in plan views.
Public enumeration FabricHostReference
Controls if Single Fabric Sheet should be cut by the Host Cover.
Public enumeration FabricLapSplicePosition
Fabric lap splice position in the fabric distribution
Public enumeration FabricLocation
Fabric location in the host
Public enumeration FabricSheetAlignment
Fabric Sheet alignment in the fabric distribution
Public enumeration FabricSheetLayoutPattern
The pattern for how the wires in Fabric Sheet are laid out.
Public enumeration FabricTagComponentReference
How FabricSheet tag text will be aligned to the FabricSheet symbol.
Public enumeration LoadOrientTo
Specifies load orientation.
Public enumeration LoadType
This enum declares types of Loads.
Public enumeration MultiplanarOption
Input argument type for Rebar.GetCenterlineCurves method. Controls whether all curves of a multi-planar Rebar element are returned by GetCenterlineCurves, or only the curves in the primary plane.
Public enumeration PositionOnCurve
Specifies position on analytical curve to calculate direction.
Public enumeration RebarConstraintTargetHostFaceType
A type to help identify the individual face on a host element to which a Rebar handle is constrained.
Public enumeration RebarConstraintType
The various types of constraints that can be applied to a RebarConstrainedHandle.
Public enumeration RebarDeformationType
Bar deformation type
Public enumeration RebarHandleType
The various types of handles on a Rebar instance that can be joined to References
Public enumeration RebarHookOrientation
Orientation of a rebar hook relative to the path of the Rebar Shape.
Public enumeration RebarHostCategory
Rebar host category
Public enumeration RebarLayoutRule
The rule for how the rebars in rebar set are laid out
Public enumeration RebarPresentationMode
Bar presentation mode
Public enumeration RebarShapeArcReferenceType
A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account by specifying whether it measures to the exterior, centerline, or interior of the bend.
Public enumeration RebarShapeBendAngle
A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
Public enumeration RebarShapeDefinitionByArcType
A RebarShapeDefinitionByArc takes one of three forms.
Public enumeration RebarShapeSegmentEndReferenceType
A choice of two reference points for one end of a constraint driving the length of a RebarShapeSegment.
Public enumeration RebarShapeVertexTurn
Specify whether a bend at a RebarShapeVertex represents a left or right turn.
Public enumeration RebarStyle
Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
Public enumeration ReinforcementRoundingSource
An enumerated type listing the possible sources for reinforcement rounding overrides.
Public enumeration SlabFoundationType
SlabFoundation type.
Public enumeration StickElementExtension
Presets for given Analytical Extension.
Public enumeration StickElementProjectionY
Presets for given Analytical Projection.
Public enumeration StickElementProjectionZ
Presets for given Analytical Projection.
Public enumeration StirrupTieAttachmentType
An enumerated tye that represents how the Stirrup/Tie rebar is attached to the cover reference.
Public enumeration StructuralConnectionApplyTo
An enumerated type that represents the type of structural locations to which a connection annotation may be applied.
Public enumeration StructuralInstanceUsage
Represents the structural usage of a family instance.
Public enumeration StructuralMaterialType
Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.
Public enumeration StructuralType
Represents the structural type of a family instance.
Public enumeration StructuralWallUsage
Represents the structural usage of a wall.
Public enumeration SurfaceElementExtension
Presets for given Analytical Extension.
Public enumeration SurfaceElementProjectionZ
Presets for given Analytical Projection Z.
Public enumeration TargetRebarConstraintType
A type used to identify the particular part of a Stirrup style rebar to which a Standard style rebar's handle is constrained.
Public enumeration TranslationRotationValue
Values for BoundaryConditions Translation and Rotation parameters.
Public enumeration TrussChordLocation
This enumerated type represents the options for the Truss Chord Location.
Public enumeration TrussCurveType
Types of curves created in truss families.
Public enumeration TrussMemberType
Indicates the "kind" of a truss member.
Public enumeration WireDistributionDirection
Defines the direction of the distribution of wires in a Fabric Sheet.
Public enumeration YJustification
The justification of the framing element in Y.
Public enumeration YZJustificationOption
The option for whether a framing element has independent or uniform justification on its ends.
Public enumeration ZJustification
The justification of the framing element in Z.