IsCropRegionShapeValid Method


Verifies that boundaries represent one closed curve loop without self-intersections, consisting of non-zero length straight lines in plane parallel to the view plane. Curves in boundaries use model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool IsCropRegionShapeValid(
	CurveLoop boundaries
)
Visual Basic
Public Function IsCropRegionShapeValid ( _
	boundaries As CurveLoop _
) As Boolean
Visual C++
public:
bool IsCropRegionShapeValid(
	CurveLoop^ boundaries
)

Parameters

boundaries
Type: Autodesk.Revit.DB CurveLoop
The crop region boundaries.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also