Deletes the specified FabricArea, and converts its FabricSheet elements to equivalent Single Fabric Sheet elements.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document.
- system
- Type: Autodesk.Revit.DB.Structure FabricArea
An FabricArea Reinforcement element in the document.
Return Value
The ids of the newly created Single Fabric Sheet elements.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The document doc does not contain the element system |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |