Sets the Building Construction of the Project Information.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- constructionType
- Type: Autodesk.Revit.DB.Analysis ConstructionType
The Construction Type of Building Construction.
- buildingConstruction
- Type: Autodesk.Revit.DB Construction
The Building Construction to be set.
Remarks
This function is used to set the Building Construction of the Project Information.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | buildingConstruction is NULL. |
Autodesk.Revit.Exceptions InvalidOperationException | Sets construction type to an invalid value. - or - Can not set construction type. |