Creates an array of new model line elements.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- geometryCurveArray
- Type: Autodesk.Revit.DB CurveArray
An array containing the internal geometry curves for model lines.
- sketchPlane
- Type: Autodesk.Revit.DB SketchPlane
Return Value
If successful an array of new model line elements. Otherwise a null reference ( Nothing in Visual Basic) .Remarks
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when curve is not in the plane |