Adds a new dockable pane to the Revit user interface.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.UI DockablePaneId
Unique identifier for the new pane.
- title
- Type: System String
String to use for the pane caption.
- provider
- Type: Autodesk.Revit.UI IDockablePaneProvider
Your add-in's implementation of the IDockablePaneProvider interface.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if a dockable pane with identifier %id% has already been registered. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if DockPosition is Floating but no FloatingRectangle has been provided, or the FloatingRectangle is not larger than 3x3. |