Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
- geometryInfo
- Type: Autodesk.Revit.DB.IFC IFCGeometryInfo
The container object which collects the geometry.
- gNode
- Type: Autodesk.Revit.DB GeometryObject
The geometry object to be processed.
- offset
- Type: Autodesk.Revit.DB XYZ
The offset to apply to each of the collected geometry handles.
- forceVisible
- Type: System Boolean
True to process geometry which is not set as visible. False to only process visible geometry.
Remarks
The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |