Adds a face to the currently open connected face set.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB TessellatedFace
Face to add. The 'face' parameter can be added only once, as its boundary loops will be cleared while adding and 'face' will become unusable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The 'face' does not have enough loops and/or vertices to be valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | A face set is closed and faces cannot be added to it. |