Sets start and end point of the line load.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- startPoint
- Type: Autodesk.Revit.DB XYZ
The start point.
- endPoint
- Type: Autodesk.Revit.DB XYZ
The end point.
Return Value
Returns true if successful, false otherwise.Remarks
This method works with non hosted line load only.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the end point is equal to the start point. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |