Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetElementIds
- Type: System.Collections.Generic ICollection ElementId
The target element ids.
- targetType
- Type: Autodesk.Revit.DB FindReferenceTarget
The target type of references to return.
- view3d
- Type: Autodesk.Revit.DB View3D
The view in which to find references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | View cannot be a template view. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |