Returns the RebarConstraint that has been set as preferred for the specified RebarConstrainedHandle.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handle
- Type: Autodesk.Revit.DB.Structure RebarConstrainedHandle
The RebarConstrainedHandle for which the user RebarConstraint is to be returned.
Return Value
The user prefered RebarConstraint applied to the RebarConstrainedHandle.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | handle is no longer valid. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |