Adds an annotation handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- annoHnd
- Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The annotation handle.
- levelInfo
- Type: Autodesk.Revit.DB.IFC IFCLevelInfo
Information on the associated level. Optional, can be a null reference ( Nothing in Visual Basic) .
- relateToLevel
- Type: System Boolean
True to relate the annotation to the level, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |