Add a grid line to the curtain grid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- isUGridLine
- Type: System Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
- position
- Type: Autodesk.Revit.DB XYZ
The position of the grid line.
- oneSegmentOnly
- Type: System Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.
Return Value
The created grid line is returned if the operation is successful. Otherwise, a null reference ( Nothing in Visual Basic) is returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown if the position for the grid line is out of range. |