Determines whether the first of two joined elements is cutting the second element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the two elements.
- firstElement
- Type: Autodesk.Revit.DB Element
The first element.
- secondElement
- Type: Autodesk.Revit.DB Element
The second element.
Return Value
True if the secondElement is cut by the firstElement, false if the secondElement is cut by the firstElement.Remarks
This functionality is not available for family documents.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |