Gets the envelope that a specified region spans.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- regionId
- Type: System Int32
The id of the region.
Return Value
The envelope of the region.Remarks
This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | It is not a valid region id. |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for vertically compound structures. |