Creates a non rectangular profile wall within the project using the default wall type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which the new wall is created.
- profile
- Type: System.Collections.Generic IList Curve
An array of planar lines and arcs that represent the vertical profile of the wall.
- structural
- Type: System Boolean
If set, specifies that the wall is structural in nature.
Return Value
If successful a new wall object within the project.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to create the wall. |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |