Adds intersecting reference with an offset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- intersectingReference
- Type: Autodesk.Revit.DB ElementId
Id of the new intersecting reference.
- offset
- Type: System Double
The Offste for the new intersecting reference.
Return Value
True if the PartMaker did not already use this intersecting reference and it was added, false if the PartMaker already used this intersecting reference and this call only updated its offset.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |