Associates a region with a layer.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- regionId
- Type: System Int32
The id of a region.
- layerIdx
- Type: System Int32
The index of a layer in this CompoundStructure.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | It is not a valid region id. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The layer index is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for vertically compound structures. |