Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that contains the element.
- elementId
- Type: Autodesk.Revit.DB ElementId
The id of the element.
Return Value
True if the element has any repeating reference sources.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element elementId does not exist in the document |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |