Creates a new boundary line as an Space border.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sketchPlane
- Type: Autodesk.Revit.DB SketchPlane
The sketch plan
- curves
- Type: Autodesk.Revit.DB CurveArray
The geometry curves on which the boundary lines are
- view
- Type: Autodesk.Revit.DB View
The View for the new Space
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the sketch plane does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the view does not exist in the given document. |