Appends an Item to the RebarContainer. Fills its data on base of the Rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rebarShape
- Type: Autodesk.Revit.DB.Structure RebarShape
A RebarShape element that defines the shape of the rebar.
- barType
- Type: Autodesk.Revit.DB.Structure RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- origin
- Type: Autodesk.Revit.DB XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
- xVector
- Type: Autodesk.Revit.DB XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
- yVector
- Type: Autodesk.Revit.DB XYZ
The y-axis in the shape definition will be mapped to this direction in the project.
Return Value
The Rebar Container Item.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The rebarShape has End Treatments |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | xVector has zero length. -or- yVector has zero length. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |