Tests the type id to make sure it satisfies the following conditions It is a valid element id.It corresponds to a valid DirectShapeType.The DirectShapeType has the same category assigned. Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- typeId
- Type: Autodesk.Revit.DB ElementId
Type id to be tested.
Return Value
False unless typeId satisfies the conditions listed above and the type id of this object was not set previously.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |