SketchedStairsCurveData Constructor


Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2015

Syntax

C#
public SketchedStairsCurveData(
	Curve boundaryCurve,
	double height,
	SketchedCurveSlopeOption slopeType
)
Visual Basic
Public Sub New ( _
	boundaryCurve As Curve, _
	height As Double, _
	slopeType As SketchedCurveSlopeOption _
)
Visual C++
public:
SketchedStairsCurveData(
	Curve^ boundaryCurve, 
	double height, 
	SketchedCurveSlopeOption slopeType
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also