Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- solidGeometry
- Type: Autodesk.Revit.DB Solid
The geometry to analyze.
- plane
- Type: Autodesk.Revit.DB Plane
The plane to use for the base plane for the extrusion.
- direction
- Type: Autodesk.Revit.DB XYZ
The direction to use for the calculation for the extrusion. The direction must be transverse to the base plane.
Return Value
The newly created ExtrusionAnalyzer object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input direction must be transverse to the input plane. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow. |