IsInstanceFlipped Method


Gets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public static bool IsInstanceFlipped(
	FamilyInstance famInst
)
Visual Basic
Public Shared Function IsInstanceFlipped ( _
	famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsInstanceFlipped(
	FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB FamilyInstance
The FamilyInstance

Return Value

True if the instance is flipped.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also