Return a transform representing the relative position of the coupler at index couplerPositionIndex in the set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- couplerPositionIndex
- Type: System Int32
An index between 0 and (CouplerQuantity-1).
Return Value
The position of a coupler in the set relative (0,0,0).Remarks
The transform is a translation along the distribution path and a rotation what will align coupler with the bar segment on which stays
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | couplerPositionIndex is not in the range [ 0, CouplerQuantity-1 ]. |