PlanCircuit Class


An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class PlanCircuit : APIObject
Visual Basic
Public Class PlanCircuit _
	Inherits APIObject
Visual C++
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

See Also