GetShellComponent Method


Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public TriangulatedShellComponent GetShellComponent(
	int componentIndex
)
Visual Basic
Public Function GetShellComponent ( _
	componentIndex As Integer _
) As TriangulatedShellComponent
Visual C++
public:
TriangulatedShellComponent^ GetShellComponent(
	int componentIndex
)

Parameters

componentIndex
Type: System Int32
The component index, must be between 0 and ShellComponentCount – 1, inclusive.

Return Value

The component.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Shell component index componentIndex is out of range.

See Also