Indicates that the caller has finished defining the given loop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- loopId
- Type: Autodesk.Revit.DB BRepBuilderGeometryId
Id of the loop.
Remarks
No functions that modify the given loop's definition should be called after calling this function (e.g., AddCoEdge(BRepBuilderGeometryId, BRepBuilderGeometryId, Boolean) ). The BRepBuilder may take the opportunity to validate some of the loop's data and report any problems it finds.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The supplied loop id doesn't correspond to a loop stored in this BRepBuilder object. -or- FinishLoop() has already been called on loopId. -or- The edge loop has fewer than two co-edges. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |