Checks if given type is valid pipe type.
Namespace:
Autodesk.Revit.DB.Plumbing
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The document.
- pipeTypeId
-
Type:
Autodesk.Revit.DB
ElementId
ElementId of the pipe type to check.
Return Value
True if pipe type can used for this pipe, false otherwise.Remarks
A type is valid for pipe if it can be used to the pipe element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |