IsPipeTypeId Method


Checks if given type is valid pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool IsPipeTypeId(
	Document document,
	ElementId pipeTypeId
)
Visual Basic
Public Shared Function IsPipeTypeId ( _
	document As Document, _
	pipeTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsPipeTypeId(
	Document^ document, 
	ElementId^ pipeTypeId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
pipeTypeId
Type: Autodesk.Revit.DBElementId
ElementId of the pipe type to check.

Return Value

True if pipe type can used for this pipe, false otherwise.

Remarks

A type is valid for pipe if it can be used to the pipe element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also