Change the type of a curtain panel.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- panel
- Type: Autodesk.Revit.DB Element
The panel to be changed, it can be a type of Panel or Wall .
- newSymbol
- Type: Autodesk.Revit.DB ElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.
Return Value
If operation succeeds, the modified panel element is returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the input symbol can't be used for the panel. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the type change failed. |